X
GO

System Requirements for I-SMART

The minimum requirements for an I-SMART computer include:

  • Windows 7 or newer, and;
  • Windows Internet Explorer 11 or higher (Chrome and Firefox browsers can be used)

NOTE:  For Windows 10 users using I-SMART in full clinical mode, the scheduler module is not compatible with Windows 10 browser - Edge or Chrome.

I-SMART is a web-based application and requires that an Internet connection be available when it is used. Because of the nature of web-based applications, the faster your connection is, the faster I-SMART will be. We strongly recommend that I-SMART be used with at least a 256 Kbps connection, faster connections are preferred (i.e., T1, DSL, Cable, etc).